summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-04-29 21:26:13 +0200
committerSander Vrijders <sander@ouroboros.rocks>2020-04-30 11:54:44 +0200
commitf6ae2ac9f0735846c58e0e953c01c3d834dd7d08 (patch)
tree541c1fea8b2b10d8abeac53f2814990126bf4efc /CMakeLists.txt
parent04a3795a70d6deb4840b30f5889e41ed42c85a6e (diff)
downloadouroboros-f6ae2ac9f0735846c58e0e953c01c3d834dd7d08.tar.gz
ouroboros-f6ae2ac9f0735846c58e0e953c01c3d834dd7d08.zip
lib: Stabilize FRCP under packet loss conditions0.17.3
There were a bunch of bugs in FRCP that urgently needed fixing. Now data QoS is usable even with heavy packet loss (within some parameters). The current RTT estimator is the IETF one. It should be updated to the improved one used in the Linux kernel once the A-timer (ACKs without data) and graceful shutdown are implemented. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9122b9e..fc728a21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ include(GNUInstallDirs)
set(PACKAGE_VERSION_MAJOR 0)
set(PACKAGE_VERSION_MINOR 17)
-set(PACKAGE_VERSION_PATCH 2)
+set(PACKAGE_VERSION_PATCH 3)
set(PACKAGE_NAME "${CMAKE_PROJECT_NAME}")
set(PACKAGE_DESCRIPTION "The Ouroboros prototype")