summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2022-03-10 08:23:15 +0100
committerSander Vrijders <sander@ouroboros.rocks>2022-03-11 17:51:27 +0100
commitf300e609e7975dacc06996d407170fe58aa49439 (patch)
treeb6210cb429de6ab1a3cd555562b8b4b15a7f82c0 /CMakeLists.txt
parenta7032da6bbe875596ea1cb348a747123cda7d408 (diff)
downloadouroboros-f300e609e7975dacc06996d407170fe58aa49439.tar.gz
ouroboros-f300e609e7975dacc06996d407170fe58aa49439.zip
lib: Fix buffer allocation when retransmitting0.19.0
The timerwheel was retransmitting packets and the error check for negative values of the rbuff allocation was instead checking for non-zero values, causing a buffer allocation to succeed but the program to continue down the unhappy path leaving that packet stuck in the buffer unattended. Also fixes wrongly scheduled retransmissions that cause packet storms. FRCP is much more stable now. Still needs some work for high bandwidth-delay products (fast-retransmit). Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eeea8f7d..c46d30c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,8 @@ project(ouroboros C)
include(GNUInstallDirs)
set(PACKAGE_VERSION_MAJOR 0)
-set(PACKAGE_VERSION_MINOR 18)
-set(PACKAGE_VERSION_PATCH 4)
+set(PACKAGE_VERSION_MINOR 19)
+set(PACKAGE_VERSION_PATCH 0)
set(PACKAGE_NAME "${CMAKE_PROJECT_NAME}")
set(PACKAGE_DESCRIPTION "The Ouroboros prototype")