summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-10-23 09:45:14 +0000
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-10-23 09:45:14 +0000
commit84b11f3322797759fef746786badcd10936dfda4 (patch)
treeae95f030431073db2035cd35fe82134a2b57536f /CMakeLists.txt
parent282aab31ebdb831725fa8192b985a1e8b0e63403 (diff)
parent322d0a2a350b63cec13f5e5dff3fc632ba0c5565 (diff)
downloadouroboros-84b11f3322797759fef746786badcd10936dfda4.tar.gz
ouroboros-84b11f3322797759fef746786badcd10936dfda4.zip
Merged in dstaesse/ouroboros/be-fix-build (pull request #272)
Be fix build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ab2f35e..ef321e4c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,14 @@ include(FindPkgConfig)
include(CompilerUtils)
test_and_set_c_compiler_flag_global(-std=c89)
test_and_set_c_compiler_flag_global(-Wall)
-test_and_set_c_compiler_flag_global(-Wextra)
+#Wextra may fail on clobbered warning due to pthread_cleanup
+#test_and_set_c_compiler_flag_global(-Wextra)
test_and_set_c_compiler_flag_global(-Werror)
test_and_set_c_compiler_flag_global(-Wundef)
test_and_set_c_compiler_flag_global(-Wpointer-arith)
test_and_set_c_compiler_flag_global(-Wstrict-prototypes)
-test_and_set_c_compiler_flag_global(-Wswitch-default)
-test_and_set_c_compiler_flag_global(-Wstrict-overflow=5)
+#Wswitch-default check fails on the swig-generated code
+#test_and_set_c_compiler_flag_global(-Wswitch-default)
test_and_set_c_compiler_flag_global(-Wunreachable-code)
test_and_set_c_compiler_flag_global(-Wdeclaration-after-statement)
test_and_set_c_compiler_flag_global(-fmax-errors=5)