summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2019-03-16 16:24:19 +0100
committerSander Vrijders <sander@ouroboros.rocks>2019-03-18 11:09:31 +0100
commit827ed1287fce61ccf4de2931bc7f477099976e2e (patch)
tree10a8e79bf4393b03c90038de4a5c424a42f9fa0b /CMakeLists.txt
parent8940fe2cc063d2de8393684ff48efec0e27edc8a (diff)
downloadouroboros-827ed1287fce61ccf4de2931bc7f477099976e2e.tar.gz
ouroboros-827ed1287fce61ccf4de2931bc7f477099976e2e.zip
build: Fix build error with swig
There is an unsafe strncpy() in the swig compilation process, which has been fixed a while back but is still not in the release version. This disables the compiler warning. It also fixes an unspecified option. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 24e025d4..5bf234d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,5 @@
cmake_minimum_required(VERSION 2.8.12.2)
+cmake_policy(VERSION 3.13)
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")