summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-06-27 12:03:31 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-06-27 12:03:31 +0200
commit80765f1d6ea16892224be8da954e5b0a4c53303b (patch)
tree8d48f58b2c3590d5f5f8d7d2d46202ff945bf3cf /CMakeLists.txt
parentb13d60ac083195af6caee475fb36844c5177a0cf (diff)
downloadouroboros-80765f1d6ea16892224be8da954e5b0a4c53303b.tar.gz
ouroboros-80765f1d6ea16892224be8da954e5b0a4c53303b.zip
build: Fix installation prefix
The installation prefix was taking a trailing backslash, while it is common not to do so. Fixed it so that any trailing backslash is removed by the compilation and installation scripts.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9875bd7c..ba900645 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,7 @@ SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
LIST(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
- "${CMAKE_INSTALL_PREFIX}usr/lib" isSystemDir)
+ "${CMAKE_INSTALL_PREFIX}/usr/lib" isSystemDir)
IF("${isSystemDir}" STREQUAL "-1")
SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/usr/lib")
ENDIF("${isSystemDir}" STREQUAL "-1")
@@ -50,7 +50,7 @@ configure_file(
"${CMAKE_CURRENT_BINARY_DIR}/ouroboros.pc"
@ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ouroboros.pc"
- DESTINATION "usr/lib/pkgconfig")
+ DESTINATION "/usr/lib/pkgconfig")
enable_testing()
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})