summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-02-22 22:35:33 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2018-02-23 12:59:18 +0100
commit7f6969bd57d6d892ad7cf97b94311d55f0957e56 (patch)
tree7c8c9ac95ac25e7179d44cc9b3b073bfce77e46a /CMakeLists.txt
parentfe9d3fcb26b6ff30f4f02f14dddcde186b2955c1 (diff)
downloadouroboros-7f6969bd57d6d892ad7cf97b94311d55f0957e56.tar.gz
ouroboros-7f6969bd57d6d892ad7cf97b94311d55f0957e56.zip
build: Deprecate version generation from git tag0.10.1
This deprecates the version generation from git tags. The version is now set in the CMakeLists.txt. This avoids wrong versions when checking out old commits and building the repository inside another repository. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5ea3bf1..acff38c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,11 +4,12 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
project(ouroboros C)
-include(GitVersionGen)
-git_version_gen()
-
include(GNUInstallDirs)
+set(PACKAGE_VERSION_MAJOR 0)
+set(PACKAGE_VERSION_MINOR 10)
+set(PACKAGE_VERSION_PATCH 1)
+
set(PACKAGE_NAME "${CMAKE_PROJECT_NAME}")
set(PACKAGE_DESCRIPTION "The Ouroboros prototype")
set(PACKAGE_URL "http://ouroboros.ilabt.imec.be")