summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-09-05 16:53:31 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-09-05 16:53:31 +0200
commit7546e75b7c3b8ed0b5cfa11c9b9b45831ab34a53 (patch)
treee4b9cc08e60d42120ce997926aa03df2876d0855 /CMakeLists.txt
parent3ed56c914851fa6eab5744213fd2e700f1ab71a8 (diff)
downloadouroboros-7546e75b7c3b8ed0b5cfa11c9b9b45831ab34a53.tar.gz
ouroboros-7546e75b7c3b8ed0b5cfa11c9b9b45831ab34a53.zip
build: Add systemd unit on install
This adds a systemd unit for the irmd on installation of Ouroboros.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4060d5f..db583144 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,14 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ouroboros.pc.in"
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ouroboros.pc"
DESTINATION "usr/lib/pkgconfig")
+if (IS_DIRECTORY "/usr/lib/systemd")
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/irmd.service.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/irmd.service" @ONLY)
+
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/irmd.service"
+ DESTINATION "usr/lib/systemd/system")
+endif ()
+
enable_testing()
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})