summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-07-26 13:37:45 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-07-26 14:37:20 +0200
commit3b1f3f57587bdb2b99934417033b24739fc0182d (patch)
tree5a823bd04ccd276b69c7faa17c517f8819cb6dd9 /CMakeLists.txt
parentbee74baa8fa8ffa71dbb659496bc88df3e8ce6a5 (diff)
downloadouroboros-3b1f3f57587bdb2b99934417033b24739fc0182d.tar.gz
ouroboros-3b1f3f57587bdb2b99934417033b24739fc0182d.zip
build: Fix wrong inclusion
The protobuf include directory was not being correctly handed to the compiler when building. Now the include directory is added project-wide. And the protobuf package is searched for only once.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7404eeb4..1918165c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,9 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
set(LOG_DIR "var/log/ouroboros")
install(DIRECTORY DESTINATION ${LOG_DIR})
+find_package(ProtobufC REQUIRED)
+include_directories(${PROTOBUF_C_INCLUDE_DIRS})
+
add_subdirectory(src)
add_subdirectory(include)