summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-02-18 17:31:19 +0100
committerSander Vrijders <sander@ouroboros.rocks>2020-02-23 14:37:27 +0100
commit00a8b8960c027848817050411e4c9be43cb6a427 (patch)
treed81d4e7a6d4f987a3cbc92bde7159a489ba97779 /CMakeLists.txt
parentce2b6900e5373041fee62328e5d1c8a30e692ea2 (diff)
downloadouroboros-00a8b8960c027848817050411e4c9be43cb6a427.tar.gz
ouroboros-00a8b8960c027848817050411e4c9be43cb6a427.zip
ipcpd: Fix infinite recursion in LFA
There were bugs introduced in the LFA algorithm refactor causing infinite recursion and SEGV. The infinite recursion check was added as an explicit compiler flag to the build. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03608b04..130e3eb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,7 @@ test_and_set_c_compiler_flag_global(-Wvla)
#test_and_set_c_compiler_flag_global(-Wswitch-default)
test_and_set_c_compiler_flag_global(-Wunreachable-code)
test_and_set_c_compiler_flag_global(-Wdeclaration-after-statement)
+test_and_set_c_compiler_flag_global(-Winfinite-recursion)
test_and_set_c_compiler_flag_global(-fmax-errors=5)
if (CMAKE_BUILD_TYPE STREQUAL "Release")
test_and_set_c_compiler_flag_global(-O3)