aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d09f64f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+from setuptools import setup
+from codecs import open
+from os import path
+
+here = path.abspath(path.dirname(__file__))
+
+with open(path.join(here, 'README'), encoding='utf-8') as f:
+ long_description = f.read()
+
+setup(
+ name = "Rhumba",
+ version = "0.1",
+ url = "https://gitlab.com/arcfire/rhumba",
+ keywords = "rina measurement testbed",
+ author = "Sander Vrijders",
+ author_email = "sander.vrijders@intec.ugent.be",
+ license = "LGPL",
+ description = "Rhumba measurement framework for RINA",
+ long_description = long_description,
+ packages = ["rhumba", "rhumba.testbeds", "rhumba.prototypes"],
+ install_requires = ["paramiko", "wheel"]
+)