summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 52061645..c986112e 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -40,7 +40,9 @@ install(FILES ${IRM_PROTO_HDRS} ${IPCP_PROTO_HDRS}
add_library(ouroboros SHARED ${SOURCE_FILES}
${IRM_PROTO_SRCS} ${IPCP_PROTO_SRCS})
-target_link_libraries(ouroboros rt pthread ${PROTOBUF_C_LIBRARY})
+
+target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
+ ${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY})
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)