summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt35
1 files changed, 30 insertions, 5 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 99dd96fc..e08869b8 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -16,7 +16,7 @@ protobuf_generate_c(FRCT_ENROLL_SRCS FRCT_ENROLL_HDRS frct_enroll.proto)
if (NOT APPLE)
find_library(LIBRT_LIBRARIES rt)
if (NOT LIBRT_LIBRARIES)
- message(FATAL_ERROR "librt not found")
+ message(FATAL_ERROR "Could not find librt.")
endif ()
else ()
set(LIBRT_LIBRARIES "")
@@ -24,9 +24,14 @@ endif ()
find_library(LIBPTHREAD_LIBRARIES pthread)
if (NOT LIBPTHREAD_LIBRARIES)
- message(FATAL_ERROR "libpthread not found")
+ message(FATAL_ERROR "Could not find libpthread.")
endif ()
+find_path(LINUX_RND_HDR
+ sys/random.h
+ HINTS /usr/include /usr/local/include
+ )
+
set(SOURCE_FILES
# Add source files here
bitmap.c
@@ -46,6 +51,7 @@ set(SOURCE_FILES
nsm.c
qos.c
qoscube.c
+ random.c
rib.c
sha3.c
shm_flow_set.c
@@ -60,14 +66,33 @@ add_library(ouroboros SHARED ${SOURCE_FILES} ${IRM_PROTO_SRCS}
${IPCP_PROTO_SRCS} ${DIF_CONFIG_PROTO_SRCS} ${CDAP_PROTO_SRCS}
${CACEP_PROTO_SRCS} ${RO_PROTO_SRCS} ${FRCT_ENROLL_SRCS})
-target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
- ${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY})
-
include(AddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
add_compile_flags(ouroboros -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
+if (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ message(STATUS "Found FreeBSD, using arc4random.")
+else()
+ if (${LINUX_RND_HDR} STREQUAL "LINUX_RND_HDR-NOTFOUND")
+ find_package(OpenSSL)
+ if (NOT OPENSSL_FOUND)
+ message(STATUS "No secure random generation, please install OpenSSL.")
+ else()
+ message(STATUS "OpenSSL found")
+ include_directories($OPENSSL_INCLUDE_DIR})
+ add_compile_flags(ouroboros -DHAVE_OPENSSL)
+ endif()
+ else ()
+ message(STATUS "Found linux random header in ${LINUX_RND_HDR}.")
+ include_directories(${LINUX_RND_HDR})
+ add_compile_flags(ouroboros -DHAVE_SYS_RANDOM)
+ endif ()
+endif()
+
+target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
+ ${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY} ${OPENSSL_LIBRARIES})
+
install(TARGETS ouroboros LIBRARY DESTINATION usr/lib)
target_include_directories(ouroboros PUBLIC ${CMAKE_CURRENT_BINARY_DIR})