summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt52
1 files changed, 26 insertions, 26 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 0427e236..52061645 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -3,48 +3,48 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(${CMAKE_SOURCE_DIR}/include)
include_directories(${CMAKE_BINARY_DIR}/include)
-find_package(ProtobufC REQUIRED)
+find_package(ProtobufC REQUIRED)
include_directories(${PROTOBUF_INCLUDE_DIRS})
-include_directories(${CMAKE_CURRENT_BINARY_DIR})
-
-protobuf_generate_c(PROTO_SRCS PROTO_HDRS irmd_messages.proto)
+protobuf_generate_c(IRM_PROTO_SRCS IRM_PROTO_HDRS irmd_messages.proto)
+protobuf_generate_c(IPCP_PROTO_SRCS IPCP_PROTO_HDRS ipcpd_messages.proto)
find_library(LIBRT_LIBRARIES rt)
if(NOT LIBRT_LIBRARIES)
- message(FATAL_ERROR "librt not found")
+ message(FATAL_ERROR "librt not found")
endif()
find_library(LIBPTHREAD_LIBRARIES pthread)
if(NOT LIBPTHREAD_LIBRARIES)
- message(FATAL_ERROR "libpthread not found")
+ message(FATAL_ERROR "libpthread not found")
endif()
set(SOURCE_FILES
- # Add source files here
- bitmap.c
- cdap.c
- da.c
- dev.c
- du_buff.c
- ipcp.c
- irm.c
- list.c
- rina_name.c
- shm_du_map.c
- sockets.c
- utils.c
- )
-
-install(FILES ${PROTO_HDRS}
- DESTINATION include/ouroboros)
-
-add_library(ouroboros SHARED ${SOURCE_FILES} ${PROTO_SRCS})
+ # Add source files here
+ bitmap.c
+ cdap.c
+ da.c
+ dev.c
+ du_buff.c
+ ipcp.c
+ irm.c
+ list.c
+ rina_name.c
+ shm_du_map.c
+ sockets.c
+ utils.c
+ )
+
+install(FILES ${IRM_PROTO_HDRS} ${IPCP_PROTO_HDRS}
+ DESTINATION include/ouroboros)
+
+add_library(ouroboros SHARED ${SOURCE_FILES}
+ ${IRM_PROTO_SRCS} ${IPCP_PROTO_SRCS})
target_link_libraries(ouroboros rt pthread ${PROTOBUF_C_LIBRARY})
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
- MACRO_ADD_COMPILE_FLAGS(ouroboros -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(ouroboros -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ouroboros LIBRARY DESTINATION lib)