summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-udp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipcpd/shim-udp/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-udp/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/ipcpd/shim-udp/CMakeLists.txt b/src/ipcpd/shim-udp/CMakeLists.txt
index 2bc68154..0319e63d 100644
--- a/src/ipcpd/shim-udp/CMakeLists.txt
+++ b/src/ipcpd/shim-udp/CMakeLists.txt
@@ -43,9 +43,10 @@ if (NSLOOKUP_EXECUTABLE AND NSUPDATE_EXECUTABLE)
if (NOT DISABLE_DNS)
message(STATUS "DDNS support enabled")
set(HAVE_DDNS TRUE CACHE INTERNAL "")
- else ()
+ else ()
message(STATUS "DDNS support disabled by user")
- endif ()
+ unset(HAVE_DDNS CACHE)
+ endif ()
else ()
if (NSLOOKUP_EXECUTABLE)
message(STATUS "Install nsupdate to enable DDNS support")