summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-eth-llc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipcpd/shim-eth-llc/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-eth-llc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/ipcpd/shim-eth-llc/CMakeLists.txt b/src/ipcpd/shim-eth-llc/CMakeLists.txt
index e9c34bbd..c3e954f7 100644
--- a/src/ipcpd/shim-eth-llc/CMakeLists.txt
+++ b/src/ipcpd/shim-eth-llc/CMakeLists.txt
@@ -28,6 +28,8 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
set(HAVE_LLC TRUE)
else ()
message(STATUS "Raw socket support for shim-eth-llc disabled by user")
+ unset(HAVE_RAW_SOCKETS)
+ unset(HAVE_LLC)
endif ()
endif ()
@@ -50,6 +52,8 @@ if (NOT CMAKE_SYSTEM_NAME STREQUAL "Linux")
else ()
message(STATUS "Berkeley Packet Filter support "
"for shim-eth-llc disabled by user")
+ unset(HAVE_BPF)
+ unset(HAVE_LLC)
endif ()
endif ()
endif ()
@@ -64,6 +68,8 @@ if (NETMAP_C_INCLUDE_DIR)
set(HAVE_LLC TRUE)
else ()
message(STATUS "Netmap support for shim-eth-llc disabled by user")
+ unset(HAVE_NETMAP)
+ unset(HAVE_LLC)
endif ()
endif ()