summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 7a40e94c..aebc6c35 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -15,6 +15,8 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE INTERNAL "")
protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS flow_alloc.proto)
+protobuf_generate_c(ENROLL_PROTO_SRCS ENROLL_PROTO_HDRS enroll.proto
+ ${CMAKE_SOURCE_DIR}/src/lib/ipcp_config.proto)
protobuf_generate_c(KAD_PROTO_SRCS KAD_PROTO_HDRS kademlia.proto)
# Add GPB sources of policies last
@@ -34,7 +36,6 @@ set(SOURCE_FILES
dt_pci.c
enroll.c
fa.c
- gam.c
main.c
neighbors.c
pff.c
@@ -42,14 +43,13 @@ set(SOURCE_FILES
routing.c
sdu_sched.c
# Add policies last
- pol/complete.c
pol/flat.c
pol/link_state.c
pol/graph.c
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${FLOW_ALLOC_SRCS} ${FSO_SRCS} ${KAD_PROTO_SRCS})
+ ${FLOW_ALLOC_SRCS} ${FSO_SRCS} ${KAD_PROTO_SRCS} ${ENROLL_PROTO_SRCS})
target_link_libraries(ipcpd-normal LINK_PUBLIC ouroboros)
include(AddCompileFlags)