summaryrefslogtreecommitdiff
path: root/src/dad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/dad/CMakeLists.txt')
-rw-r--r--src/dad/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/dad/CMakeLists.txt b/src/dad/CMakeLists.txt
index 3d4b8ea7..1f9f4f42 100644
--- a/src/dad/CMakeLists.txt
+++ b/src/dad/CMakeLists.txt
@@ -13,4 +13,12 @@ add_executable (dad ${SOURCE_FILES})
target_link_libraries (dad LINK_PUBLIC ouroboros)
-install(TARGETS dad RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(dad -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
+install(TARGETS dad RUNTIME DESTINATION bin)
+
+# Enable once dad has tests
+# add_subdirectory(tests)