summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index b4f04cf2..dc827fbe 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -1,6 +1,16 @@
-file(GLOB_RECURSE HEADER_FILES *.h)
+set(HEADER_FILES
+ bitmap.h
+ cdap.h
+ common.h
+ da.h
+ dev.h
+ du_buff.h
+ ipcp.h
+ irm.h
+ list.h
+ logs.h
+ sockets.h
+)
install(FILES ${HEADER_FILES}
- DESTINATION ${CMAKE_INSTALL_FULL_INCLUDEDIR}/ouroboros)
-
-add_custom_target(qtcreator-workaround SOURCES ${HEADER_FILES})
+ DESTINATION include/ouroboros)