summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ca05c95..c3495e6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 3.1.0)
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
#set(CMAKE_VERBOSE_MAKEFILE ON)
-project(ouroboros)
+project(ouroboros C)
include(GitVersionGen)
GIT_VERSION_GEN()
@@ -27,13 +27,16 @@ message(STATUS "Package URL is: ${PACKAGE_URL}")
message(STATUS "Package bug-report address: ${PACKAGE_BUGREPORT}")
message(STATUS "Package install prefix: ${CMAKE_INSTALL_PREFIX}")
+# Enable C89 standard
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c89")
+
include(FindPkgConfig)
include(CompilerUtils)
-test_and_set_cxx_compiler_flag_global(-Wall)
-test_and_set_cxx_compiler_flag_global(-Werror)
-test_and_set_cxx_compiler_flag_global(-Wundef)
-test_and_set_cxx_compiler_flag_global(-fmax-errors=1)
+test_and_set_c_compiler_flag_global(-Wall)
+test_and_set_c_compiler_flag_global(-Werror)
+test_and_set_c_compiler_flag_global(-Wundef)
+test_and_set_c_compiler_flag_global(-fmax-errors=1)
configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/ouroboros.pc.in"
@@ -46,7 +49,7 @@ add_subdirectory(include)
add_subdirectory(src)
add_subdirectory(tests)
-# We may have to move this to the subdirs
+# FIXME: We may have to move this to the subdirs
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
MACRO_ADD_COMPILE_FLAGS(ipcpd -DCONFIG_OUROBOROS_DEBUG)