summaryrefslogtreecommitdiff
path: root/src/tools/operf/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-10-30 14:04:03 +0000
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-10-30 14:04:03 +0000
commit94044e99af295e9440d306719a5cf341645d1803 (patch)
tree49e677cf3626a58737fd3d2d7ac8b0dd7a74517f /src/tools/operf/CMakeLists.txt
parent72eb9eed1284643db20c45ef82365fa54fd0ef1c (diff)
parent05fa4879dd8c70156fd98eabed4634098b0feecb (diff)
downloadouroboros-94044e99af295e9440d306719a5cf341645d1803.tar.gz
ouroboros-94044e99af295e9440d306719a5cf341645d1803.zip
Merged in dstaesse/ouroboros/be-dealloc (pull request #293)
operf tool, bugfixing and small improvements
Diffstat (limited to 'src/tools/operf/CMakeLists.txt')
-rw-r--r--src/tools/operf/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/tools/operf/CMakeLists.txt b/src/tools/operf/CMakeLists.txt
new file mode 100644
index 00000000..b63d24ee
--- /dev/null
+++ b/src/tools/operf/CMakeLists.txt
@@ -0,0 +1,21 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+find_library(LIBM_LIBRARIES m)
+if(NOT LIBM_LIBRARIES)
+ message(FATAL_ERROR "libm not found")
+endif()
+
+set(SOURCE_FILES
+ # Add source files here
+ operf.c
+)
+
+add_executable(operf ${SOURCE_FILES})
+
+target_link_libraries(operf LINK_PUBLIC ${LIBM_LIBRARIES} ouroboros)
+
+install(TARGETS operf RUNTIME DESTINATION usr/bin)