summaryrefslogtreecommitdiff
path: root/src/tools/cbr/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-05-24 20:38:01 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-05-24 20:45:30 +0200
commitd74d67a0e2d3de0ec208ed9b839815a70d84f727 (patch)
tree4abe39734cd5eda97ef3453ed234133c7f16d2ae /src/tools/cbr/CMakeLists.txt
parent82622409f7b32b697581837a9392a83342a45ad6 (diff)
downloadouroboros-d74d67a0e2d3de0ec208ed9b839815a70d84f727.tar.gz
ouroboros-d74d67a0e2d3de0ec208ed9b839815a70d84f727.zip
tools, lib: cbr tool for bandwidth testing
The tool sends constant bandwidth traffic between a client and a server. cbr --help for more info. Adds time_utils.h to the library containing useful functions for arithmetic with timespec and timeval structures.
Diffstat (limited to 'src/tools/cbr/CMakeLists.txt')
-rw-r--r--src/tools/cbr/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/tools/cbr/CMakeLists.txt b/src/tools/cbr/CMakeLists.txt
new file mode 100644
index 00000000..7c3f93f8
--- /dev/null
+++ b/src/tools/cbr/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+set(SOURCE_FILES
+ # Add source files here
+ cbr.c
+)
+
+add_executable(cbr ${SOURCE_FILES})
+
+target_link_libraries(cbr LINK_PUBLIC ouroboros)
+
+install(TARGETS cbr RUNTIME DESTINATION bin)