summaryrefslogtreecommitdiff
path: root/src/nsmd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-08-21 09:11:38 +0000
committerSander Vrijders <sander.vrijders@ugent.be>2017-08-21 09:11:38 +0000
commit5b242e7207483860143d3c84438134430ac1448f (patch)
treea04a750b802436a4e244d8224b800a2f26071091 /src/nsmd/CMakeLists.txt
parentafe8b6f496dd4e0e3aaaa5dec0d6fb32253a49f7 (diff)
parent8f58e5a3ec0e4a15fc8ae0911cc864f5dbf86c6e (diff)
downloadouroboros-5b242e7207483860143d3c84438134430ac1448f.tar.gz
ouroboros-5b242e7207483860143d3c84438134430ac1448f.zip
Merged in dstaesse/ouroboros/be-build (pull request #557)
build: Revise the build system
Diffstat (limited to 'src/nsmd/CMakeLists.txt')
-rw-r--r--src/nsmd/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/src/nsmd/CMakeLists.txt b/src/nsmd/CMakeLists.txt
deleted file mode 100644
index 2995b725..00000000
--- a/src/nsmd/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-include_directories(${CMAKE_CURRENT_BINARY_DIR})
-
-include_directories(${CMAKE_SOURCE_DIR}/include)
-include_directories(${CMAKE_BINARY_DIR}/include)
-
-set(SOURCE_FILES
- # Add source files here
- main.c
- )
-
-add_executable(nsmd ${SOURCE_FILES})
-
-target_link_libraries(nsmd LINK_PUBLIC ouroboros)
-
-include(AddCompileFlags)
-if (CMAKE_BUILD_TYPE MATCHES Debug)
- add_compile_flags(nsmd -DCONFIG_OUROBOROS_DEBUG)
-endif (CMAKE_BUILD_TYPE MATCHES Debug)
-
-install(TARGETS nsmd RUNTIME DESTINATION sbin)
-
-# Enable once nsmd has tests
-# add_subdirectory(tests)