summaryrefslogtreecommitdiff
path: root/src/nsmd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-06-20 21:58:17 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-06-20 21:58:17 +0200
commit34f96731f5fb8ab8a1f7018366fc28fd041d73e2 (patch)
treeaff0b0ed3474c7cdb5f6ba7e62ca5e33ccedb814 /src/nsmd/CMakeLists.txt
parent6270143e57306d11be5c02ee3c7857808583c0f5 (diff)
parent550cfa775b048abe183c4fdcc8ada8476e562185 (diff)
downloadouroboros-34f96731f5fb8ab8a1f7018366fc28fd041d73e2.tar.gz
ouroboros-34f96731f5fb8ab8a1f7018366fc28fd041d73e2.zip
Merged in sandervrijders/ouroboros/be (pull request #134)
build: Change install directories and set correct permissions
Diffstat (limited to 'src/nsmd/CMakeLists.txt')
-rw-r--r--src/nsmd/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/nsmd/CMakeLists.txt b/src/nsmd/CMakeLists.txt
new file mode 100644
index 00000000..b916170b
--- /dev/null
+++ b/src/nsmd/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+set(SOURCE_FILES
+ # Add source files here
+ main.c
+)
+
+add_executable (nsmd ${SOURCE_FILES})
+
+target_link_libraries (nsmd LINK_PUBLIC ouroboros)
+
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(nsmd -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
+install(TARGETS nsmd RUNTIME DESTINATION sbin)
+
+# Enable once nsmd has tests
+# add_subdirectory(tests)