summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-11 15:50:16 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-11 15:50:16 +0100
commitf78310f4886bad7029cc039971159ab7a97e00af (patch)
treec1609e42197af649ab52888a0c50186218f7a3d8 /src/lib/CMakeLists.txt
parent5f3ee106ad32e07e8d00513212eb0968a84b59a1 (diff)
downloadouroboros-f78310f4886bad7029cc039971159ab7a97e00af.tar.gz
ouroboros-f78310f4886bad7029cc039971159ab7a97e00af.zip
Initial build infrastructure
Contains the initial build infrastructure. Cmake was chosen for portability reasons.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
new file mode 100644
index 00000000..5099fa48
--- /dev/null
+++ b/src/lib/CMakeLists.txt
@@ -0,0 +1,14 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+set(SOURCE_FILES
+ # Add source files here
+ cdap.c
+)
+
+add_library(ouroboros SHARED ${SOURCE_FILES})
+
+install(TARGETS ouroboros LIBRARY DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR})