summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-04-11 17:02:55 +0200
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-04-11 17:02:55 +0200
commitdbe01cb34001f06519a42e9c21d144f52e7d8758 (patch)
tree046635cd3ca941f0debad37fa0865357b5b62a41 /src/lib/CMakeLists.txt
parent1d5c9ae5c7c77f200e9670bbee714adad983136e (diff)
parent9906ac98c45530e530d7aa439937aedf526c3508 (diff)
downloadouroboros-dbe01cb34001f06519a42e9c21d144f52e7d8758.tar.gz
ouroboros-dbe01cb34001f06519a42e9c21d144f52e7d8758.zip
Merged in sandervrijders/ouroboros/be (pull request #54)
Dif config now correctly passed to the IPCP
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 1f7b0f55..c2d1bcc7 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -8,6 +8,8 @@ find_package(ProtobufC REQUIRED)
include_directories(${PROTOBUF_INCLUDE_DIRS})
protobuf_generate_c(IRM_PROTO_SRCS IRM_PROTO_HDRS irmd_messages.proto)
protobuf_generate_c(IPCP_PROTO_SRCS IPCP_PROTO_HDRS ipcpd_messages.proto)
+protobuf_generate_c(DIF_CONFIG_PROTO_SRCS DIF_CONFIG_PROTO_HDRS
+ dif_config.proto)
find_library(LIBRT_LIBRARIES rt)
if(NOT LIBRT_LIBRARIES)
@@ -36,11 +38,11 @@ set(SOURCE_FILES
utils.c
)
-install(FILES ${IRM_PROTO_HDRS} ${IPCP_PROTO_HDRS}
+install(FILES ${IRM_PROTO_HDRS} ${IPCP_PROTO_HDRS} ${DIF_CONFIG_PROTO_HDRS}
DESTINATION include/ouroboros)
add_library(ouroboros SHARED ${SOURCE_FILES}
- ${IRM_PROTO_SRCS} ${IPCP_PROTO_SRCS})
+ ${IRM_PROTO_SRCS} ${IPCP_PROTO_SRCS} ${DIF_CONFIG_PROTO_SRCS})
target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY})