summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-14 10:30:55 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-14 10:30:55 +0100
commit9bca11727451f364f180758b46051a8e0398bccd (patch)
tree012305da5a6811e0aebd50ae4e1e09709441dfc4 /src/lib/CMakeLists.txt
parent516f9b24bc11d70353e9bcafea9b9098ad9f0a45 (diff)
downloadouroboros-9bca11727451f364f180758b46051a8e0398bccd.tar.gz
ouroboros-9bca11727451f364f180758b46051a8e0398bccd.zip
lib: Move list function definitions into a source file
This moves the function definitions of list.h into a separate source file to avod linker errors when including the file in more than one source file.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index c52a5609..589c8769 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -12,6 +12,7 @@ set(SOURCE_FILES
du_buff.c
ipcp.c
irm.c
+ list.c
rina_name.c
sockets.c
)