summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2017-02-21 10:56:35 +0000
committerSander Vrijders <sander.vrijders@intec.ugent.be>2017-02-21 10:56:35 +0000
commit91091367210ee204c4082a0da05eea3336674f19 (patch)
treecd0facb94108552b0b9e75619af4e42d77be1a17 /src/lib/CMakeLists.txt
parentbf27d8fec3c8051f0518420b4b0ef2957147a887 (diff)
parentadc6766221327f99ab484d66f6f92050ec9e62d7 (diff)
downloadouroboros-91091367210ee204c4082a0da05eea3336674f19.tar.gz
ouroboros-91091367210ee204c4082a0da05eea3336674f19.zip
Merged in dstaesse/ouroboros/be-cacep (pull request #383)
lib: Exchange protocol info during CACEP
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index f823b2d1..fcea0fb2 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -10,6 +10,10 @@ protobuf_generate_c(DIF_CONFIG_PROTO_SRCS DIF_CONFIG_PROTO_HDRS
dif_config.proto)
protobuf_generate_c(CDAP_PROTO_SRCS CDAP_PROTO_HDRS cdap.proto)
protobuf_generate_c(RO_PROTO_SRCS RO_PROTO_HDRS ro.proto)
+protobuf_generate_c(CACEP_PROTO_PROTO_SRCS CACEP_CDAP_PROTO_HDRS
+ pol/cacep_proto.proto)
+protobuf_generate_c(CACEP_ANONYMOUS_AUTH_PROTO_SRCS
+ CACEP_ANONYMOUS_AUTH_PROTO_HDRS pol/cacep_anonymous_auth.proto)
protobuf_generate_c(CACEP_SIMPLE_AUTH_PROTO_SRCS CACEP_SIMPLE_AUTH_PROTO_HDRS
pol/cacep_simple_auth.proto)
@@ -51,12 +55,14 @@ set(SOURCE_FILES
time_utils.c
utils.c
# Add policies last
+ pol/cacep_proto.c
pol/cacep_anonymous_auth.c
pol/cacep_simple_auth.c
)
add_library(ouroboros SHARED ${SOURCE_FILES} ${IRM_PROTO_SRCS}
${IPCP_PROTO_SRCS} ${DIF_CONFIG_PROTO_SRCS} ${CDAP_PROTO_SRCS}
+ ${CACEP_PROTO_PROTO_SRCS} ${CACEP_ANONYMOUS_AUTH_PROTO_SRCS}
${CACEP_SIMPLE_AUTH_PROTO_SRCS} ${RO_PROTO_SRCS})
target_link_libraries(ouroboros ${LIBRT_LIBRARIES}