summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-03 17:15:57 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-03 17:15:57 +0100
commit486b601ecb6d79c90eadc4dda0981e25e6a7ba1d (patch)
tree6366cb8555cf3588839a2866f4825bf708ac3f11 /src/lib/CMakeLists.txt
parent52a5113760802e16b07d9d954237871d52cff70a (diff)
downloadouroboros-486b601ecb6d79c90eadc4dda0981e25e6a7ba1d.tar.gz
ouroboros-486b601ecb6d79c90eadc4dda0981e25e6a7ba1d.zip
build: Move debugging switch to correct CMakeLists
This moves the debugging switch down to the CMakeList associated with every program or library. It allows to build apps individually with debugging info on or off.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 2e0d6b6b..535726a9 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -15,4 +15,9 @@ set(SOURCE_FILES
add_library(ouroboros SHARED ${SOURCE_FILES})
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(ouroboros -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
install(TARGETS ouroboros LIBRARY DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR})