summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-08-31 14:29:32 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-08-31 14:29:32 +0200
commit857c014a40a75eda574af8b2002b1c794bc0975c (patch)
tree721c6c6a7b394dc758ffa12bb3a1261d9817207f /src/lib/CMakeLists.txt
parent1071824054828b9be36f50416f858c49c9acd701 (diff)
parent63b63e0f6ab9f743fc34623bb1caa9852227f046 (diff)
downloadouroboros-857c014a40a75eda574af8b2002b1c794bc0975c.tar.gz
ouroboros-857c014a40a75eda574af8b2002b1c794bc0975c.zip
Merge branch 'be' of bitbucket.org:ouroboros-rina/ouroboros into be
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 8c058dd8..14e7051a 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -11,9 +11,13 @@ protobuf_generate_c(DIF_CONFIG_PROTO_SRCS DIF_CONFIG_PROTO_HDRS
protobuf_generate_c(CDAP_PROTO_SRCS CDAP_PROTO_HDRS
cdap.proto)
-find_library(LIBRT_LIBRARIES rt)
-if(NOT LIBRT_LIBRARIES)
- message(FATAL_ERROR "librt not found")
+if(NOT APPLE)
+ find_library(LIBRT_LIBRARIES rt)
+ if(NOT LIBRT_LIBRARIES)
+ message(FATAL_ERROR "librt not found")
+ endif()
+else()
+ set(LIBRT_LIBRARIES "")
endif()
find_library(LIBPTHREAD_LIBRARIES pthread)