summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-07-25 19:54:39 +0200
committerdimitri staessens <dimitri.staessens@ugent.be>2017-07-26 10:39:51 +0200
commit809abada865727ea986d69afcf2a9a3b00df560a (patch)
treee6cdc6bfba21e87be04df6d6fa62490813d94ce3 /src/lib/CMakeLists.txt
parent36343a9c19fca9494881a9529b5fbbb0d51c1900 (diff)
downloadouroboros-809abada865727ea986d69afcf2a9a3b00df560a.tar.gz
ouroboros-809abada865727ea986d69afcf2a9a3b00df560a.zip
lib: Add threadpool manager
This adds a threadpool manager component in the library that is used in the IRMd and IPCPs. The threadpool manager now doesn't detach threads but does a join when they exit. This solves a data race in the previous implementation where some threads were not completely finished upon release of some resources.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index e08869b8..822c8c9b 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -59,6 +59,7 @@ set(SOURCE_FILES
shm_rdrbuff.c
sockets.c
time_utils.c
+ tpm.c
utils.c
)