summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-03-03 15:01:50 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2017-03-03 15:01:50 +0100
commit2852bb1bac8fcc111364d516c2bd31628ad264c7 (patch)
tree58fa873269b656272f3628c5dd1777270b988455 /src/lib/CMakeLists.txt
parent13e438d5bc2350cf3d71a77f6d3c5a54ba436161 (diff)
downloadouroboros-2852bb1bac8fcc111364d516c2bd31628ad264c7.tar.gz
ouroboros-2852bb1bac8fcc111364d516c2bd31628ad264c7.zip
build: Format CMakeLists.txt files
The CMakeLists files are now properly indented.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 03452705..f6a30ef7 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -12,19 +12,19 @@ protobuf_generate_c(CDAP_PROTO_SRCS CDAP_PROTO_HDRS cdap.proto)
protobuf_generate_c(RO_PROTO_SRCS RO_PROTO_HDRS ro.proto)
protobuf_generate_c(CACEP_PROTO_SRCS CACEP_PROTO_HDRS cacep.proto)
-if(NOT APPLE)
+if (NOT APPLE)
find_library(LIBRT_LIBRARIES rt)
- if(NOT LIBRT_LIBRARIES)
+ if (NOT LIBRT_LIBRARIES)
message(FATAL_ERROR "librt not found")
- endif()
-else()
+ endif ()
+else ()
set(LIBRT_LIBRARIES "")
-endif()
+endif ()
find_library(LIBPTHREAD_LIBRARIES pthread)
-if(NOT LIBPTHREAD_LIBRARIES)
+if (NOT LIBPTHREAD_LIBRARIES)
message(FATAL_ERROR "libpthread not found")
-endif()
+endif ()
set(SOURCE_FILES
# Add source files here
@@ -58,9 +58,9 @@ add_library(ouroboros SHARED ${SOURCE_FILES} ${IRM_PROTO_SRCS}
target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY})
-include(MacroAddCompileFlags)
+include(AddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
- MACRO_ADD_COMPILE_FLAGS(ouroboros -DCONFIG_OUROBOROS_DEBUG)
+ add_compile_flags(ouroboros -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ouroboros LIBRARY DESTINATION usr/lib)