summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-08-31 14:24:10 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-08-31 14:24:10 +0200
commit63b63e0f6ab9f743fc34623bb1caa9852227f046 (patch)
tree721c6c6a7b394dc758ffa12bb3a1261d9817207f /src/lib/CMakeLists.txt
parent52db4952d80a10aae464274acdd7401267818b28 (diff)
parent04eb03136466a18d81511e7ccadf51c08faa8edb (diff)
downloadouroboros-63b63e0f6ab9f743fc34623bb1caa9852227f046.tar.gz
ouroboros-63b63e0f6ab9f743fc34623bb1caa9852227f046.zip
Merged in dstaesse/ouroboros/be-apple (pull request #230)
lib, ipcp: Compile on Apple junk
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 8c058dd8..14e7051a 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -11,9 +11,13 @@ protobuf_generate_c(DIF_CONFIG_PROTO_SRCS DIF_CONFIG_PROTO_HDRS
protobuf_generate_c(CDAP_PROTO_SRCS CDAP_PROTO_HDRS
cdap.proto)
-find_library(LIBRT_LIBRARIES rt)
-if(NOT LIBRT_LIBRARIES)
- message(FATAL_ERROR "librt not found")
+if(NOT APPLE)
+ find_library(LIBRT_LIBRARIES rt)
+ if(NOT LIBRT_LIBRARIES)
+ message(FATAL_ERROR "librt not found")
+ endif()
+else()
+ set(LIBRT_LIBRARIES "")
endif()
find_library(LIBPTHREAD_LIBRARIES pthread)