summaryrefslogtreecommitdiff
path: root/src/irmd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-08-08 21:15:57 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-08-08 21:15:57 +0200
commit18e440197cae6d537765a4de6a915f074dce4de5 (patch)
tree5f55b8d82826fc182c9408350200b7ecaa932a27 /src/irmd/CMakeLists.txt
parentc2b7a0bf9978091c9a51b72fdbd94cc9286041df (diff)
downloadouroboros-18e440197cae6d537765a4de6a915f074dce4de5.tar.gz
ouroboros-18e440197cae6d537765a4de6a915f074dce4de5.zip
irmd: Refactor and bugfixes
Refactors the IRMd to extract reg_api and irm_flow structures to their own sources. Fixes some locking bugs.
Diffstat (limited to 'src/irmd/CMakeLists.txt')
-rw-r--r--src/irmd/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/irmd/CMakeLists.txt b/src/irmd/CMakeLists.txt
index bf810d96..89fbae08 100644
--- a/src/irmd/CMakeLists.txt
+++ b/src/irmd/CMakeLists.txt
@@ -6,7 +6,9 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(SOURCE_FILES
# Add source files here
+ irm_flow.c
main.c
+ reg_api.c
registry.c
utils.c
)