summaryrefslogtreecommitdiff
path: root/src/irmd/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2018-05-29 10:04:41 +0200
committerDimitri Staessens <dimitri.staessens@ugent.be>2018-05-29 10:47:29 +0200
commitc24d3376c306e2c1f6c893d597cf80ef40a40f4b (patch)
tree09251a38a76ac7231f658c50201abf4b0c0b6b8c /src/irmd/CMakeLists.txt
parentf634f4b0961c8fb143f3ff54ea91f32f5d412ab9 (diff)
downloadouroboros-c24d3376c306e2c1f6c893d597cf80ef40a40f4b.tar.gz
ouroboros-c24d3376c306e2c1f6c893d597cf80ef40a40f4b.zip
build: Update default values0.11.7
This sets updated default values for the default build. A higher connect timeout until we have asynchronous local IPC. Disabled SWIG since the lastest gcc reports an error. IPCP flow stats enabled by default since their impact on the performance is very limited. Waiting for the directory to enroll before returning to increase stability. Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be> Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be>
Diffstat (limited to 'src/irmd/CMakeLists.txt')
-rw-r--r--src/irmd/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/irmd/CMakeLists.txt b/src/irmd/CMakeLists.txt
index 51719dcf..458e1efa 100644
--- a/src/irmd/CMakeLists.txt
+++ b/src/irmd/CMakeLists.txt
@@ -18,7 +18,7 @@ set(REG_TIMEOUT 10000 CACHE STRING
"Timeout for registering a name (ms)")
set(QUERY_TIMEOUT 3000 CACHE STRING
"Timeout to query a name with an IPCP (ms)")
-set(CONNECT_TIMEOUT 5000 CACHE STRING
+set(CONNECT_TIMEOUT 60000 CACHE STRING
"Timeout to connect an IPCP to another IPCP (ms)")
set(IRMD_MIN_THREADS 8 CACHE STRING
"Minimum number of worker threads in the IRMd.")