summaryrefslogtreecommitdiff
path: root/src/ipcpd/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-03-29 17:55:14 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-03-29 17:56:47 +0200
commitd90c66cc6beba511f6bcc48a3ea3fc4e774b5ab8 (patch)
treefe2b5bc70090c5c4bd29a2e8f2e11c19436dea24 /src/ipcpd/tests/CMakeLists.txt
parente43fd05ba896ad5b4ac390f6097d6e6a06308f28 (diff)
downloadouroboros-d90c66cc6beba511f6bcc48a3ea3fc4e774b5ab8.tar.gz
ouroboros-d90c66cc6beba511f6bcc48a3ea3fc4e774b5ab8.zip
ipcpd: normal: Add graph regression test
This adds a regression test for the graph component to test the routing table.
Diffstat (limited to 'src/ipcpd/tests/CMakeLists.txt')
-rw-r--r--src/ipcpd/tests/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/ipcpd/tests/CMakeLists.txt b/src/ipcpd/tests/CMakeLists.txt
index 07430127..9b5eeaa1 100644
--- a/src/ipcpd/tests/CMakeLists.txt
+++ b/src/ipcpd/tests/CMakeLists.txt
@@ -12,20 +12,23 @@ include_directories(${CURRENT_BINARY_PARENT_DIR})
include_directories(${CMAKE_SOURCE_DIR}/include)
include_directories(${CMAKE_BINARY_DIR}/include)
-create_test_sourcelist(${src_folder}_tests test_suite.c
+get_filename_component(PARENT_PATH ${CMAKE_CURRENT_SOURCE_DIR} DIRECTORY)
+get_filename_component(PARENT_DIR ${PARENT_PATH} NAME)
+
+create_test_sourcelist(${PARENT_DIR}_tests test_suite.c
# Add new tests here
timerwheel_test.c
)
-add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})
-target_link_libraries(${src_folder}_test ouroboros)
+add_executable(${PARENT_DIR}_test EXCLUDE_FROM_ALL ${${PARENT_DIR}_tests})
+target_link_libraries(${PARENT_DIR}_test ouroboros)
-add_dependencies(check ${src_folder}_test)
+add_dependencies(check ${PARENT_DIR}_test)
-set(tests_to_run ${${src_folder}_tests})
+set(tests_to_run ${${PARENT_DIR}_tests})
remove(tests_to_run test_suite.c)
foreach (test ${tests_to_run})
get_filename_component(test_name ${test} NAME_WE)
- add_test(${test_name} ${C_TEST_PATH}/${src_folder}_test ${test_name})
+ add_test(${test_name} ${C_TEST_PATH}/${PARENT_DIR}_test ${test_name})
endforeach (test)