summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-udp/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-05-10 18:42:00 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-05-10 18:42:00 +0200
commitba8b2ba46a5b499004272c9acc9049539b600082 (patch)
tree857de7ccf8303aba1bc36db56cbf0e7120479913 /src/ipcpd/shim-udp/CMakeLists.txt
parentdfda83926c50297d7c315f743b4514f687469c9c (diff)
downloadouroboros-ba8b2ba46a5b499004272c9acc9049539b600082.tar.gz
ouroboros-ba8b2ba46a5b499004272c9acc9049539b600082.zip
ipcpd: Add nslookup to shim UDP
This adds nslookup support to the shim UDP, so that a custom DNS server can be queried.
Diffstat (limited to 'src/ipcpd/shim-udp/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-udp/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/ipcpd/shim-udp/CMakeLists.txt b/src/ipcpd/shim-udp/CMakeLists.txt
index a50fe8bd..e10a8ca6 100644
--- a/src/ipcpd/shim-udp/CMakeLists.txt
+++ b/src/ipcpd/shim-udp/CMakeLists.txt
@@ -40,6 +40,18 @@ if (NOT DISABLE_DNS MATCHES True)
else()
message("-- Found nsupdate: ${NSUPDATE_EXECUTABLE}")
endif()
+
+ # Find the nslookup executable
+ find_program(NSLOOKUP_EXECUTABLE
+ NAMES nslookup
+ DOC "The nslookup tool that resolves DNS names")
+
+ if (${NSLOOKUP_EXECUTABLE} STREQUAL "NSLOOKUP_EXECUTABLE-NOTFOUND")
+ message(FATAL_ERROR
+ "Could not find nslookup, which is needed for DNS resolution")
+ else()
+ message("-- Found nslookup: ${NSLOOKUP_EXECUTABLE}")
+ endif()
endif()
configure_file(