summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-eth-llc/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2017-11-17 19:24:14 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2017-11-18 11:03:44 +0100
commit3fc5c6532f1a56f27310fb733a089e1064716b10 (patch)
treee331109cd47dac48d803bd405ae41a83b40b9b5f /src/ipcpd/shim-eth-llc/CMakeLists.txt
parentdb505a91d035b5942113c2eace2e356894f60fc8 (diff)
downloadouroboros-3fc5c6532f1a56f27310fb733a089e1064716b10.tar.gz
ouroboros-3fc5c6532f1a56f27310fb733a089e1064716b10.zip
build: Fix setting configuration definitions
Variable in cache need to be explicitly unset else they will remain in the cache and still be defined by #cmakedefine. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/shim-eth-llc/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-eth-llc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/ipcpd/shim-eth-llc/CMakeLists.txt b/src/ipcpd/shim-eth-llc/CMakeLists.txt
index e9c34bbd..c3e954f7 100644
--- a/src/ipcpd/shim-eth-llc/CMakeLists.txt
+++ b/src/ipcpd/shim-eth-llc/CMakeLists.txt
@@ -28,6 +28,8 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
set(HAVE_LLC TRUE)
else ()
message(STATUS "Raw socket support for shim-eth-llc disabled by user")
+ unset(HAVE_RAW_SOCKETS)
+ unset(HAVE_LLC)
endif ()
endif ()
@@ -50,6 +52,8 @@ if (NOT CMAKE_SYSTEM_NAME STREQUAL "Linux")
else ()
message(STATUS "Berkeley Packet Filter support "
"for shim-eth-llc disabled by user")
+ unset(HAVE_BPF)
+ unset(HAVE_LLC)
endif ()
endif ()
endif ()
@@ -64,6 +68,8 @@ if (NETMAP_C_INCLUDE_DIR)
set(HAVE_LLC TRUE)
else ()
message(STATUS "Netmap support for shim-eth-llc disabled by user")
+ unset(HAVE_NETMAP)
+ unset(HAVE_LLC)
endif ()
endif ()