summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-eth-llc/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-12-03 21:30:30 +0100
committerDimitri Staessens <dimitri.staessens@ugent.be>2017-12-04 11:35:57 +0100
commite85cd46dd2888fe6d327420e73893c048c221900 (patch)
tree137530288c9abb15319e254850649141ce4bc5a0 /src/ipcpd/shim-eth-llc/CMakeLists.txt
parent9b8a3e11c558877c09416991ff1ec840fea6d0ab (diff)
downloadouroboros-e85cd46dd2888fe6d327420e73893c048c221900.tar.gz
ouroboros-e85cd46dd2888fe6d327420e73893c048c221900.zip
ipcpd: Remove protocol buffers from shim-eth-llc
This will remove google protocol buffers from the shim-eth-llc. It now uses packed structs, as supported by the compilers of choice. Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be> Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be>
Diffstat (limited to 'src/ipcpd/shim-eth-llc/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-eth-llc/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/ipcpd/shim-eth-llc/CMakeLists.txt b/src/ipcpd/shim-eth-llc/CMakeLists.txt
index 56e25457..b1d2196c 100644
--- a/src/ipcpd/shim-eth-llc/CMakeLists.txt
+++ b/src/ipcpd/shim-eth-llc/CMakeLists.txt
@@ -76,8 +76,6 @@ endif ()
if (HAVE_LLC)
message(STATUS "Supported raw Ethernet API found, building shim-eth-llc")
- protobuf_generate_c(SHIM_ETH_LLC_PROTO_SRCS SHIM_ETH_LLC_PROTO_HDRS
- shim_eth_llc_messages.proto)
set(SHIM_ETH_LLC_SOURCES
# Add source files here
@@ -86,8 +84,7 @@ if (HAVE_LLC)
set(IPCP_SHIM_ETH_LLC_TARGET ipcpd-shim-eth-llc CACHE INTERNAL "")
- add_executable(ipcpd-shim-eth-llc ${SHIM_ETH_LLC_SOURCES} ${IPCP_SOURCES}
- ${SHIM_ETH_LLC_PROTO_SRCS})
+ add_executable(ipcpd-shim-eth-llc ${SHIM_ETH_LLC_SOURCES} ${IPCP_SOURCES})
if (HAVE_BPF AND NOT APPLE)
target_include_directories(ipcpd-shim-eth-llc PUBLIC ${BPF_C_INCLUDE_DIR})
@@ -98,8 +95,7 @@ if (HAVE_LLC)
${NETMAP_C_INCLUDE_DIR})
endif ()
- target_link_libraries(ipcpd-shim-eth-llc LINK_PUBLIC ouroboros-dev
- ${PROTOBUF_C_LIBRARY})
+ target_link_libraries(ipcpd-shim-eth-llc LINK_PUBLIC ouroboros-dev)
include(AddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES "Debug*")