summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-eth-llc/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-06-05 16:49:32 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-06-14 14:05:28 +0200
commitaeb53fcd725fe291afa6ffb683373c8e589afa64 (patch)
tree3f9840107501dc98472406dadfa16eba860ca61b /src/ipcpd/shim-eth-llc/CMakeLists.txt
parenta76b638a370cd0cdd087ec780e6b1f8d18bac66d (diff)
downloadouroboros-aeb53fcd725fe291afa6ffb683373c8e589afa64.tar.gz
ouroboros-aeb53fcd725fe291afa6ffb683373c8e589afa64.zip
ipcpd: Adds a shim over IEEE 802.2 over IEEE 802.3
This adds a shim over LLC over Ethernet. It uses the raw socket API to send messages directly over an interface.
Diffstat (limited to 'src/ipcpd/shim-eth-llc/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-eth-llc/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/ipcpd/shim-eth-llc/CMakeLists.txt b/src/ipcpd/shim-eth-llc/CMakeLists.txt
new file mode 100644
index 00000000..14441113
--- /dev/null
+++ b/src/ipcpd/shim-eth-llc/CMakeLists.txt
@@ -0,0 +1,37 @@
+get_filename_component(CURRENT_SOURCE_PARENT_DIR
+ ${CMAKE_CURRENT_SOURCE_DIR} DIRECTORY)
+get_filename_component(CURRENT_BINARY_PARENT_DIR
+ ${CMAKE_CURRENT_BINARY_DIR} DIRECTORY)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CURRENT_SOURCE_PARENT_DIR})
+include_directories(${CURRENT_BINARY_PARENT_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+find_package(ProtobufC REQUIRED)
+include_directories(${PROTOBUF_INCLUDE_DIRS})
+protobuf_generate_c(SHIM_ETH_LLC_PROTO_SRCS SHIM_ETH_LLC_PROTO_HDRS
+ shim_eth_llc_messages.proto)
+
+SET(IPCP_SHIM_ETH_LLC_TARGET ipcpd-shim-eth-llc
+ CACHE STRING "IPCP_SHIM_ETH_LLC_TARGET")
+
+set(SHIM_ETH_LLC_SOURCES
+ # Add source files here
+ ${CMAKE_CURRENT_SOURCE_DIR}/main.c)
+
+add_executable (ipcpd-shim-eth-llc ${SHIM_ETH_LLC_SOURCES} ${IPCP_SOURCES}
+ ${SHIM_ETH_LLC_PROTO_SRCS})
+target_link_libraries (ipcpd-shim-eth-llc LINK_PUBLIC ouroboros
+ ${PROTOBUF_C_LIBRARY})
+
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(ipcpd-shim-eth-llc -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
+install(TARGETS ipcpd-shim-eth-llc RUNTIME DESTINATION bin)