summaryrefslogtreecommitdiff
path: root/src/ipcpd/shim-eth-llc/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-08-23 12:39:40 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-08-23 12:39:40 +0200
commit3c1f1088bdfc369a91f3b52d5a69552acc5e268d (patch)
tree1f499c0d6c7b8aedaecb1f11296fc7e01d36dea4 /src/ipcpd/shim-eth-llc/CMakeLists.txt
parente18aed70c85d778c66412c01d5d1fc2a06708aed (diff)
downloadouroboros-3c1f1088bdfc369a91f3b52d5a69552acc5e268d.tar.gz
ouroboros-3c1f1088bdfc369a91f3b52d5a69552acc5e268d.zip
ipcpd: shim-eth-llc: Fix building LLC shim
The LLC shim was not being built even though it should be build. This is due to CMake behaviour that when you set a var in the parent scope, it is not set in the local scope. It also adds back THIS_TYPE to the shim-eth-llc.
Diffstat (limited to 'src/ipcpd/shim-eth-llc/CMakeLists.txt')
-rw-r--r--src/ipcpd/shim-eth-llc/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/ipcpd/shim-eth-llc/CMakeLists.txt b/src/ipcpd/shim-eth-llc/CMakeLists.txt
index 6474eb8d..e10a715f 100644
--- a/src/ipcpd/shim-eth-llc/CMakeLists.txt
+++ b/src/ipcpd/shim-eth-llc/CMakeLists.txt
@@ -25,6 +25,7 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
if (NOT DISABLE_RAW_SOCKETS)
message(STATUS "Raw socket support for shim-eth-llc enabled")
set(HAVE_RAW_SOCKETS TRUE PARENT_SCOPE)
+ set(HAVE_LLC TRUE)
else ()
message(STATUS "Raw socket support for shim-eth-llc disabled by user")
endif ()
@@ -45,6 +46,7 @@ if (NOT CMAKE_SYSTEM_NAME STREQUAL "Linux")
message(STATUS "Berkeley Packet Filter support "
"for shim-eth-llc enabled")
set(HAVE_BPF TRUE PARENT_SCOPE)
+ set(HAVE_LLC TRUE)
else ()
message(STATUS "Berkeley Packet Filter support "
"for shim-eth-llc disabled by user")
@@ -59,12 +61,13 @@ if (NETMAP_C_INCLUDE_DIR)
message(STATUS "Netmap support for shim-eth-llc enabled")
set(HAVE_NETMAP TRUE PARENT_SCOPE)
test_and_set_c_compiler_flag_global(-std=c99)
+ set(HAVE_LLC TRUE)
else ()
message(STATUS "Netmap support for shim-eth-llc disabled by user")
endif ()
endif ()
-if (HAVE_NETMAP OR HAVE_BPF OR HAVE_RAW_SOCKETS)
+if (HAVE_LLC)
message(STATUS "Supported raw Ethernet API found, building shim-eth-llc")
protobuf_generate_c(SHIM_ETH_LLC_PROTO_SRCS SHIM_ETH_LLC_PROTO_HDRS
shim_eth_llc_messages.proto)