summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-04-19 18:36:59 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-04-19 18:43:45 +0200
commitfa70f932b4a6ad5849e1fd68906157619c09341f (patch)
tree8a32bc6bba24b60177c119f3e6ce16c2ae1fea72 /src/ipcpd/normal/CMakeLists.txt
parentbfc295d012efe5117734a2d6799c90af61102a68 (diff)
downloadouroboros-fa70f932b4a6ad5849e1fd68906157619c09341f.tar.gz
ouroboros-fa70f932b4a6ad5849e1fd68906157619c09341f.zip
ipcpd: normal: Extract SDU scheduling component
This extracts the SDU scheduling component out of the Flow Manager since the functionality was duplicated. For both the N-1 and N+1 flow sets an SDU scheduling component is now created.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 69615d0c..2045b8df 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -32,6 +32,7 @@ set(SOURCE_FILES
pff.c
ribmgr.c
routing.c
+ sdu_sched.c
shm_pci.c
# Add policies last
pol/complete.c