summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-11-16 17:46:41 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-11-19 17:18:59 +0100
commitf8632a11faed3402e8255f368b8eff58f3b2eadb (patch)
treef257dcb876b3258456593a5dda3b1b806acddd01 /src/ipcpd/normal/CMakeLists.txt
parentdf172e82d2a5058bd0af8d49b6a0854f6a2ada6a (diff)
downloadouroboros-f8632a11faed3402e8255f368b8eff58f3b2eadb.tar.gz
ouroboros-f8632a11faed3402e8255f368b8eff58f3b2eadb.zip
ipcpd: normal: Add syncing of RIB objects
This adds the remote syncing of RIB objects. Subscribers are notified upon receipt of new/deleted/updated RIB objects.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 08c5c691..06e41e9c 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -20,6 +20,8 @@ protobuf_generate_c(STATIC_INFO_SRCS STATIC_INFO_HDRS
protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS
flow_alloc.proto)
+protobuf_generate_c(RO_SRCS RO_HDRS ro.proto)
+
set(SOURCE_FILES
# Add source files here
addr_auth.c
@@ -34,7 +36,7 @@ set(SOURCE_FILES
)
add_executable (ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${STATIC_INFO_SRCS} ${FLOW_ALLOC_SRCS})
+ ${STATIC_INFO_SRCS} ${FLOW_ALLOC_SRCS} ${RO_SRCS})
target_link_libraries (ipcpd-normal LINK_PUBLIC ouroboros)
include(MacroAddCompileFlags)