summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-05-14 18:32:49 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-05-14 18:32:49 +0200
commitaf1dff6fc06f55d6565589282ac4ebacc53b4d29 (patch)
treedaa33b67da40cd2b7677126fa15fb996cbba25f2 /src/ipcpd/normal/CMakeLists.txt
parentaff55f153ddb247357f59b3740477e90eba527bd (diff)
downloadouroboros-af1dff6fc06f55d6565589282ac4ebacc53b4d29.tar.gz
ouroboros-af1dff6fc06f55d6565589282ac4ebacc53b4d29.zip
lib, ipcpd, irmd: Add QoS cube definition
This adds the QoS cube definition, which is an enum to select which QoS is needed in the IPCP. An application has to use the qos_spec in qos.h to define what it needs. The IRMd will map this unto a qos cube definition. Some headers are now also no longer installed on the system, since they are only to be used within the irmd and ipcps.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index c13cbaa3..58584e20 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -1,5 +1,7 @@
-get_filename_component(CURRENT_SOURCE_PARENT_DIR ${CMAKE_CURRENT_SOURCE_DIR} DIRECTORY)
-get_filename_component(CURRENT_BINARY_PARENT_DIR ${CMAKE_CURRENT_BINARY_DIR} DIRECTORY)
+get_filename_component(CURRENT_SOURCE_PARENT_DIR
+ ${CMAKE_CURRENT_SOURCE_DIR} DIRECTORY)
+get_filename_component(CURRENT_BINARY_PARENT_DIR
+ ${CMAKE_CURRENT_BINARY_DIR} DIRECTORY)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
include_directories(${CMAKE_CURRENT_BINARY_DIR})