summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2017-03-02 15:29:11 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2017-03-02 16:01:35 +0100
commit9d2fbef7b8569aac930c95ca1afb92a5dec79dac (patch)
tree7c4931890ee54d9bac331ac6031f411ddac08527 /src/ipcpd/normal/CMakeLists.txt
parenta5796c7f02570a2878f9c6a5d28dca80beabed12 (diff)
downloadouroboros-9d2fbef7b8569aac930c95ca1afb92a5dec79dac.tar.gz
ouroboros-9d2fbef7b8569aac930c95ca1afb92a5dec79dac.zip
ipcpd: normal: Add connection manager
This adds the connection manager which allows the different AEs of the normal IPCP to register with it. An AE can then use the connection manager to allocate a flow to a neighbor, or to wait for a new connection from a neighbor.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 7e10cc0d..70742336 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -20,6 +20,7 @@ set(SOURCE_FILES
# Add source files here
addr_auth.c
cdap_flow.c
+ connmgr.c
dir.c
enroll.c
fmgr.c