summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-07-14 16:52:54 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-07-14 16:52:54 +0200
commit8d1951e463193c1aa213c4680f645ec7b9247e15 (patch)
tree9f75f0987f7acfd5c26fc90ecbb3cf81b585ec47 /src/ipcpd/normal/CMakeLists.txt
parentd96bac100c5fe181383e947c1e62241cbabce6ac (diff)
downloadouroboros-8d1951e463193c1aa213c4680f645ec7b9247e15.tar.gz
ouroboros-8d1951e463193c1aa213c4680f645ec7b9247e15.zip
ipcpd: normal: Establish N-1 management flows
This adds the intial implementation of establishing management N-1 flows between normal IPCPs. On calling fmgr_mgmt_flow, a management flow will be setup to a certain destination IPCP. After flow allocation, the fd is handed to the RIB manager. The flow manager also listens for incoming flow requests. In case they are management flows, they are handed to the RIB manager, otherwise to the FRCT.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 5aefeabb..7e6d9266 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -17,6 +17,9 @@ SET(IPCP_NORMAL_TARGET ipcpd-normal CACHE STRING "IPCP_NORMAL_TARGET")
set(SOURCE_FILES
# Add source files here
main.c
+ fmgr.c
+ frct.c
+ ribmgr.c
)
add_executable (ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES})