summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-03-14 16:06:33 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2017-03-14 16:06:33 +0100
commit7714673b65daf1fd0266d2855d9bfc91d735b51a (patch)
tree3c7aa5e8bf1144767fbadc79dd5a33a0d0b95404 /src/ipcpd/normal/CMakeLists.txt
parent366fcbec4fb7de21c553f24efb977b45bf27f2e6 (diff)
downloadouroboros-7714673b65daf1fd0266d2855d9bfc91d735b51a.tar.gz
ouroboros-7714673b65daf1fd0266d2855d9bfc91d735b51a.zip
ipcpd: normal: Add graph structure
This adds a graph structure which will be updated by routing when it is notified about a new RIB event. The routing can then use this graph as input for calculating the shortest path to a destination.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index af99b3f9..39ced7bc 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -25,6 +25,7 @@ set(SOURCE_FILES
fmgr.c
frct.c
gam.c
+ graph.c
main.c
neighbors.c
pff.c