summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-11-29 11:48:17 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-11-29 13:54:21 +0100
commit60a6970f4d004a3bdaedc5af4e1581890ab9b462 (patch)
tree44149f4d89d02ebb246b4cb53414e848b320d031 /src/ipcpd/normal/CMakeLists.txt
parentea71b87be592fec7eb8f5ae0707503c4f0fba8be (diff)
downloadouroboros-60a6970f4d004a3bdaedc5af4e1581890ab9b462.tar.gz
ouroboros-60a6970f4d004a3bdaedc5af4e1581890ab9b462.zip
ipcpd: normal: Complete flat address policy
This will add a check in the flat address policy to see if the address is in use or not.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt25
1 files changed, 13 insertions, 12 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 06e41e9c..c4525b1a 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -23,17 +23,18 @@ protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS
protobuf_generate_c(RO_SRCS RO_HDRS ro.proto)
set(SOURCE_FILES
- # Add source files here
- addr_auth.c
- cdap_request.c
- crc32.c
- flat.c
- fmgr.c
- frct.c
- main.c
- ribmgr.c
- shm_pci.c
-)
+ # Add source files here
+ addr_auth.c
+ cdap_request.c
+ crc32.c
+ fmgr.c
+ frct.c
+ main.c
+ ribmgr.c
+ shm_pci.c
+ # Add policies last
+ pol/flat.c
+ )
add_executable (ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
${STATIC_INFO_SRCS} ${FLOW_ALLOC_SRCS} ${RO_SRCS})
@@ -41,7 +42,7 @@ target_link_libraries (ipcpd-normal LINK_PUBLIC ouroboros)
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
- macro_add_compile_flags(ipcpd-normal -DCONFIG_OUROBOROS_DEBUG)
+ macro_add_compile_flags(ipcpd-normal -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ipcpd-normal RUNTIME DESTINATION sbin)