summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-03-15 17:15:19 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2017-03-20 11:42:45 +0100
commit5fde9be8b30f284b4a249fbf13b08af290b868b1 (patch)
tree07e171269a9802a4e0db01063d7d147f894c8352 /src/ipcpd/normal/CMakeLists.txt
parent7714673b65daf1fd0266d2855d9bfc91d735b51a (diff)
downloadouroboros-5fde9be8b30f284b4a249fbf13b08af290b868b1.tar.gz
ouroboros-5fde9be8b30f284b4a249fbf13b08af290b868b1.zip
ipcpd: normal: routing: Listen to RIB events
This lets the routing component listen to RIB events. It listens to /fsdb which is populated with FSOs. The graph that is kept within the routing component is updated depending on the event that was received.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 39ced7bc..06292c50 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -15,6 +15,7 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE STRING "IPCP_NORMAL_TARGET")
protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS flow_alloc.proto)
+protobuf_generate_c(FSO_SRCS FSO_HDRS fso.proto)
set(SOURCE_FILES
# Add source files here
@@ -38,7 +39,7 @@ set(SOURCE_FILES
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${FLOW_ALLOC_SRCS})
+ ${FLOW_ALLOC_SRCS} ${FSO_SRCS})
target_link_libraries(ipcpd-normal LINK_PUBLIC ouroboros)
include(AddCompileFlags)