summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-05-15 18:08:53 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-05-15 18:21:45 +0200
commit5d87cec1757c4e1c23ae778f2814363c1e39b43c (patch)
treeea57e4a1e634d3b7e7325b61f6dba36d941e03ae /src/ipcpd/normal/CMakeLists.txt
parent0fc0f3701ef4f504e71eadcc92a93faf1dd33bf4 (diff)
downloadouroboros-5d87cec1757c4e1c23ae778f2814363c1e39b43c.tar.gz
ouroboros-5d87cec1757c4e1c23ae778f2814363c1e39b43c.zip
ipcpd: normal: Make routing a policy
This makes the routing component into a policy since different approaches may exist to do this, depending on how high the rank of the DIF is.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 984ebd3d..336b0e8f 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -15,7 +15,8 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE STRING "IPCP_NORMAL_TARGET")
protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS flow_alloc.proto)
-protobuf_generate_c(FSO_SRCS FSO_HDRS fso.proto)
+# Add GPB sources of policies last
+protobuf_generate_c(FSO_SRCS FSO_HDRS pol/fso.proto)
set(SOURCE_FILES
# Add source files here
@@ -27,7 +28,6 @@ set(SOURCE_FILES
enroll.c
fa.c
gam.c
- graph.c
main.c
neighbors.c
pff.c
@@ -37,6 +37,8 @@ set(SOURCE_FILES
# Add policies last
pol/complete.c
pol/flat.c
+ pol/link_state.c
+ pol/graph.c
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
@@ -50,5 +52,4 @@ endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ipcpd-normal RUNTIME DESTINATION sbin)
-# Enable once ipcp-normal has tests
-add_subdirectory(tests)
+add_subdirectory(pol/tests)