summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-10-31 19:47:45 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-11-01 09:38:20 +0100
commit2d88fdaaa018d607eca5ce057dfbdf41beb6125b (patch)
treef5085671663fa6798065d283619b6e8997e0f51b /src/ipcpd/normal/CMakeLists.txt
parent72eb9eed1284643db20c45ef82365fa54fd0ef1c (diff)
downloadouroboros-2d88fdaaa018d607eca5ce057dfbdf41beb6125b.tar.gz
ouroboros-2d88fdaaa018d607eca5ce057dfbdf41beb6125b.zip
ipcpd: normal: Add policy for obtaining a flat address
This adds a policy for obtaining a flat address, and thus also the infrastructure for policies in the IPCP. The IPCP should check if the address is available; this is currently not there yet.
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 151721a2..08c5c691 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -22,8 +22,10 @@ protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS
set(SOURCE_FILES
# Add source files here
+ addr_auth.c
cdap_request.c
crc32.c
+ flat.c
fmgr.c
frct.c
main.c